android – Cannot change dependencies of configuration ':app:api' after it has been included in dependency resolution-ThrowExceptions

Exception or error:

Cannot change dependencies of configuration ‘:app:api’ after it has been included in dependency resolution.

How to solve:

I was also getting the same error. Thanks to @Dominik for linking to the duplicate issue.

For now the work around is to downgrade com.google.gms:google-services to version 3.2.1 while the Android team works on a fix.

###

For today you can use

classpath 'com.google.gms:google-services:4.0.2'

Seems it works.

Leave a Reply

Your email address will not be published. Required fields are marked *