android – Emulator not running-ThrowExceptions

Exception or error:

My AVD Emulator is not running after I changed my Hardisk to other MotherBoard i5 3GHz processor without re-installing OS.

OS: Ubuntu 10.10

my emulator is not running thru eclipse. when I click Run As.. Android application.

Then I try to run thru the command prompt then its showing some error as below.

padmakumar@padmakumar-desktop:~$ emulator -avd JellyBelly
Failed to create Context 0x3005
emulator: WARNING: Could not initialize OpenglES emulation, using software renderer.
Segmentation fault

how to resolve this error to run the emulator?

EDIT: using emulator -avd JellyBelly -verbose

padmakumar@padmakumar-desktop:~$ emulator -avd JellyBelly -verbose
emulator: found SDK root at /home/padmakumar/android-sdk
emulator: Android virtual device file at: /home/padmakumar/.android/avd/JellyBelly.ini
emulator: virtual device content at /home/padmakumar/.android/avd/JellyBelly.avd
emulator: virtual device config file: /home/padmakumar/.android/avd/JellyBelly.avd/config.ini
emulator: using core hw config path: /home/padmakumar/.android/avd/JellyBelly.avd/hardware-qemu.ini
emulator: Found AVD target API level: 16
emulator: found skin 'WXGA800-7in' in directory: /home/padmakumar/android-sdk/platforms/android-16/skins
emulator: autoconfig: -skin WXGA800-7in
emulator: autoconfig: -skindir /home/padmakumar/android-sdk/platforms/android-16/skins
emulator: found skin-specific hardware.ini: /home/padmakumar/android-sdk/platforms/android-16/skins/WXGA800-7in/hardware.ini
emulator: keyset loaded from: /home/padmakumar/.android/default.keyset
emulator: trying to load skin file '/home/padmakumar/android-sdk/platforms/android-16/skins/WXGA800-7in/layout'
emulator: skin network speed: 'full'
emulator: skin network delay: 'none'
emulator: autoconfig: -kernel /home/padmakumar/android-sdk/system-images/android-16/armeabi-v7a//kernel-qemu
emulator: autoconfig: -ramdisk /home/padmakumar/android-sdk/system-images/android-16/armeabi-v7a//ramdisk.img
emulator: Using initial system image: /home/padmakumar/android-sdk/system-images/android-16/armeabi-v7a//system.img
emulator: autoconfig: -data /home/padmakumar/.android/avd/JellyBelly.avd/userdata-qemu.img
emulator: autoconfig: -initdata /home/padmakumar/.android/avd/JellyBelly.avd/userdata.img
emulator: autoconfig: -cache /home/padmakumar/.android/avd/JellyBelly.avd/cache.img
emulator: autoconfig: -sdcard /home/padmakumar/.android/avd/JellyBelly.avd/sdcard.img
emulator: Physical RAM size: 1024MB

Content of hardware configuration file:
  hw.cpu.arch = arm
  hw.cpu.model = cortex-a8
  hw.ramSize = 1024
  hw.screen = touch
  hw.mainKeys = no
  hw.trackBall = yes
  hw.keyboard = no
  hw.keyboard.lid = no
  hw.keyboard.charmap = qwerty2
  hw.dPad = yes
  hw.gsmModem = yes
  hw.gps = yes
  hw.battery = yes
  hw.accelerometer = yes
  hw.audioInput = yes
  hw.audioOutput = yes
  hw.sdCard = yes
  hw.sdCard.path = /home/padmakumar/.android/avd/JellyBelly.avd/sdcard.img
  disk.cachePartition = yes
  disk.cachePartition.path = /home/padmakumar/.android/avd/JellyBelly.avd/cache.img
  disk.cachePartition.size = 66m
  hw.lcd.width = 800
  hw.lcd.height = 1280
  hw.lcd.depth = 16
  hw.lcd.density = 213
  hw.lcd.backlight = yes
  hw.gpu.enabled = no
  hw.camera.back = emulated
  hw.camera.front = none
  vm.heapSize = 48
  hw.sensors.proximity = yes
  hw.sensors.magnetic_field = yes
  hw.sensors.orientation = yes
  hw.sensors.temperature = yes
  kernel.path = /home/padmakumar/android-sdk/system-images/android-16/armeabi-v7a//kernel-qemu
  kernel.parameters =  android.checkjni=1
  disk.ramdisk.path = /home/padmakumar/android-sdk/system-images/android-16/armeabi-v7a//ramdisk.img
  disk.systemPartition.initPath = /home/padmakumar/android-sdk/system-images/android-16/armeabi-v7a//system.img
  disk.systemPartition.size = 200m
  disk.dataPartition.path = /home/padmakumar/.android/avd/JellyBelly.avd/userdata-qemu.img
  disk.dataPartition.size = 201m
  avd.name = JellyBelly
.
QEMU options list:
emulator: argv[00] = "/home/padmakumar/android-sdk/tools/emulator-arm"
emulator: argv[01] = "-android-hw"
emulator: argv[02] = "/home/padmakumar/.android/avd/JellyBelly.avd/hardware-qemu.ini"
Concatenated QEMU options:
 /home/padmakumar/android-sdk/tools/emulator-arm -android-hw /home/padmakumar/.android/avd/JellyBelly.avd/hardware-qemu.ini
emulator: registered 'boot-properties' qemud service
emulator: nand_add_dev: system,size=0xc800000,initfile=/home/padmakumar/android-sdk/system-images/android-16/armeabi-v7a//system.img
emulator: mapping 'system' NAND image to /tmp/android-padmakumar/emulator-IM8Usk
emulator: rounding devsize up to a full eraseunit, now c810000

emulator: nand_add_dev: userdata,size=0xc900000,file=/home/padmakumar/.android/avd/JellyBelly.avd/userdata-qemu.img
emulator: rounding devsize up to a full eraseunit, now c918000

emulator: registered 'boot-properties' qemud service
emulator: Adding boot property: 'dalvik.vm.heapsize' = '48m'
emulator: Adding boot property: 'qemu.sf.lcd_density' = '213'
emulator: Adding boot property: 'qemu.hw.mainkeys' = '0'
emulator: Adding boot property: 'qemu.sf.fake_camera' = 'back'
emulator: nand_add_dev: cache,size=0x4200000,file=/home/padmakumar/.android/avd/JellyBelly.avd/cache.img
emulator: Initializing hardware OpenGLES emulation support
Failed to create Context 0x3005
emulator: Can't start OpenGLES renderer?
emulator: WARNING: Could not initialize OpenglES emulation, using software renderer.
emulator: Kernel parameters: qemu.gles=0 qemu=1 console=ttyS0 android.qemud=ttyS1 android.checkjni=1 ndns=2
Segmentation fault

Edit: whatever emulator I am creating is not running.

How to solve:

It is actually happen when you upgrade your ADT and SDK to the 20th version…
That occurs with many people but the solution is you have to start “emulator-arm” instead of “emulator”… so may be it works…
and for more detail you can refer http://code.google.com/p/android/issues/detail?id=34233 this link…

###

I had the same problem

Edit your AVD GUI settings.
Hardware Section, select New.
Hit the “Property” Dropdown
Select “GPU Emulation” then “OK”
Change “Gpu Emulation” to “YES” with the dropdown in Hardware Section.

Save and try again

###

You are probably missing the link with the GLES libraries for the emulator, make sure that in

<Android SDK root>/tools/lib

you have this .so files

libEGL_translator.so    
libGLES_CM_translator.so    
libGLES_V2_translator.so    
libOpenglRender.so

you have to add this files to the global set of libraries for your OS, you can add libraries from a specific path doing just the following:

  • sudo gedit /etc/ld.so.conf.d/androidGL.conf
  • write only the path to libraries in this file, in your case <Android SDK root>/tools/lib, just a path, do not specify any library, all the libraries in that path will be automatically collected
  • save and close gedit
  • update the global set of libraries to add the new path with sudo ldconfig

now re-try to run your avd.

###

Failed to create Context 0x3005
emulator: Can't start OpenGLES renderer?

generally this thing happens when your emulator size is out range compare to your OS Support GL drives .

try to scale your emulator according to your screen size and monitor dpi .

Hope it will help .

###

Change the resolution of your screen(increase).That did the trick for me

###

I too was having this problem. My symptoms:

  1. I could start Android sessions
  2. Eclipse then displayed the above error
  3. I use Windows Vista, Android SDK 20 and Eclipse 4.2.0

The actual issue was quite straight forward (noting I did have GPU emulator = yes). It turns out that Eclipse couldn’t see the Android session!

http://www.linkedin.com/groups/Problem-in-executing-code-on-86481.S.138513463

As such I found

Android Emulator starts but Eclipse doesn't recognize it

Restarted ADB server and bobs your uncle (also restarting Eclipse) solution in hand!

I hope that helps someone else.

###

You will have to set all the environment variable path values again. and if you used the installer file to install the sdk you may require to install it again cause it has some dependencies with OS.

###

If you use Windows 8 64 bit with intel processor and NVidia graphics card you should install Windows updates.
Specifically : NViDIA driver update for GForce, and intel corporation driver update for HD Graphics.

###

There is nothing to be worried about this error you are not creating your Avd according to platform Just Make it Proper will showing you an example

1 -Android 2.2 ,
2 -Api Level 8 ,
3 -SDCard 1024

Will definitely work just make it according the Platform!

###

I was having this issue with windows 8 x64. make sure u install the correct driver for your graphics card. The error went away after i installed the correct driver.

###

All i did to fix this was :

  1. Removed Device from AVD manager
  2. Create Virtual Device again

###

Try this:

  1. Open AVD Manager
  2. Click on the JellyBelly AVD
  3. Click Edit
  4. Change some value in ‘Hardware’ and save it

Try starting it and let us know how it goes

Leave a Reply

Your email address will not be published. Required fields are marked *