android – Error: "The graphics preview in the layout editor may not be accurate: Paint.setShadowLayer is not supported"-ThrowExceptions

Exception or error:

I’m using Eclipse and I just created a home page (menu) with 2 image buttons, but I am getting this error:

The graphics preview in the layout editor may not be accurate:

Paint.setShadowLayer is not supported.

What does it mean? And how can I solve it?

I am using API 21.

How to solve:

It means the preview doesn’t know how to implement setShadowLayer. This means the preview won’t look exactly like the result rendered on the device. Which is one of many reasons why you shouldn’t trust the preview app- always test your layouts on a physical device before assuming they’re done.

###

In my case it was a new component, a EditText with support of showing/hiding a password. It appeared in support library v.24.2.0. I mean:

<android.support.design.widget.TextInputLayout
    android:id="@+id/password_input_layout"
    android:layout_width="match_parent"
    android:layout_height="wrap_content"
    android:layout_marginBottom="0dp"
    app:passwordToggleEnabled="true">

    <android.support.design.widget.TextInputEditText
        android:id="@+id/password"
        android:layout_width="match_parent"
        android:layout_height="wrap_content"
        android:background="@android:color/transparent"
        android:hint="@string/password"
        android:inputType="textPassword"
        tools:text="aaaaaaaaaaaaaaaaaaa"/>
</android.support.design.widget.TextInputLayout>

Of course, on a real device it is shown right (and in preview also).

###

As the first answer is true, but for fixing this issue you can try this (If you are using android studio) :

File > Invalidate Caches / Restart... > Invalidate and Restart

Leave a Reply

Your email address will not be published. Required fields are marked *