android – Failed to open the HAX device! HAX is not working and emulator runs in emulation mode emulator-ThrowExceptions

Exception or error:

My Android emulator is running properly but it is showing this error every time I start the
emulator.

Starting emulator for AVD AVD_for_Nexus_4 emulator: Failed to open the
HAX device! HAX is not working and emulator runs in emulation mode
emulator: Open HAX device failed emulator: emulator window was out of
view and was recentered

I do not understand what is the exact problem.

How to solve:

I think you are trying to run an emulator based on x86. I got the same error when I just download the HAXM under Extras category of Android SDK Manager. Actually, you need install it.
Go to the directory of extras and run the installation of HAXM. Hope this will solve your problem.

###

The solution of Rohan will fix the problem as the error message will not be shown but the emulator will not use the hardware acceleration and thus be again very slow.

I recommend instead to install the Intel Hardware Accelerated Execution Manager as described here:

https://stackoverflow.com/a/10772162/891479

###

I had the same problem recently.

First you need to install HAXM in the Android SDK Manager (from the error message I think you already did that). This will enable the emulator to use the HAXM framework, and for this it needs to open the HAX device. On your system this cannot be found, hence the error message.

To make this device available, you need to install the HAXM driver from Intel. You can find it here: http://software.intel.com/en-us/android/articles/intel-hardware-accelerated-execution-manager (You also need to enable virtualization in your computer BIOS).

Hope this helps.

###

I just had to uninstall HAXM and install it again. Then it started working again. Hope this helps someone!

Edit:

Oh wow, this was a long time ago. I have been using genymotion for a few months now, and never had any issues like that.

###

If you found “HAX is not working and emulator runs in emulation mode” problem while running android SDK. This mean your computer CPU must be intel core and must support “Hardware Accelerated Execution Manager”. It means that you have configured the emulator in a way which is not supported by your operating system.

See this link solving the problem http://www.javaexperience.com/hax-is-not-working-and-emulator-runs-in-emulation-mode/#ixzz2p3inMj34

Update : –

The link is down at the moment so posting archieved link of the webpage –
https://web.archive.org/web/20151024002104/http://www.javaexperience.com/hax-is-not-working-and-emulator-runs-in-emulation-mode/

If your CPU isn’t intel, then you have to edit your AVD and choose “CPU/ABI” as “ARM”. For more details, please visit the link above.

###

I had the same problem. Just after enabling Internet Virtualization from BIOS. After that let the system boot and install HAXM once again. Now emulator will run faster than before and HAXM will work. Enjoy!!

###

Check if the RAM configured in HAX installation is equal or lower than your AVD RAM (How to fix: "HAX is not working and emulator runs in emulation mode") that fixed mine.

###

I had this error and the other fixes didn’t help me, but changing the CPU type the emulator used did get it working.

Create a new emulator and try using mips or arm for the cpu selection

Leave a Reply

Your email address will not be published. Required fields are marked *