android – Non-upgradable APK error after trying to upgrade my appbundle-ThrowExceptions

Exception or error:

I’ve released my first Flutter app for pre-order few weeks ago and now i’d like to upgrade that release.
I’ve increased both version and build in pubspec.yaml but if i try to upgrade the release on the developer console i get this error :

Non-upgradable APK
Warning:
None of the users of this APK will be able to upgrade to any of the new APKs added in this release.
Tip:
Ensure that all your new APKs are added to this release.

Do i need to increase the versions somewhere else?

SOLVED:
Was trying to upgrade from 0.0.5 to 0.0.7, then tried to upgrade to 1.0.0 and it solved the problem.

How to solve:

Leave a Reply

Your email address will not be published. Required fields are marked *