build.gradle – implementation 'com.android.support:appcompat-v7:28.0.0'-ThrowExceptions

Exception or error:

I am moving my first steps with app programming.

I searched the other topics that relate to this matter and tried all the solutions but still it’s driving me mad:

building on Android Studio I cannot make it through this error about

implementation 'com.android.support:appcompat-v7:28.0.0' :

All com.android.support libraries must use the exact same version specification (mixing versions can lead to runtime crashes).

Found versions 28.0.0, 26.1.0.

Examples include

com.android.support:animated-vector-drawable:28.0.0

and

com.android.support:support-v4:26.1.0

There are some combinations of libraries, or tools and libraries, that are incompatible, or can lead to bugs. One such incompatibility is compiling with a version of the Android support libraries that is not the latest version (or in particular, a version lower than your targetSdkVersion).

if i ignore it with the command “noinspection” then the apk does not run on my phone. I tried to add some dependencies like in the example line but it doesn’t work at this point i show above, because if add “support version 4:26.1.0 it tells me it’s not the latest and if i upgrade it writing 7:28.0.0 it doesn’t work either.

Can anyone help me please?
Thank you for your time!

Edit: this is my build.gradle
https://www.dropbox.com/sh/1vjmrh196bdy5gn/AADW-DG1YB10s-Csw_UrZtuYa?dl=0

I applied suggestions below (THANKS!!) and the error is not showing anymore, BUT my app still crashes both in emulator and in my device (galaxy a6+).

How to solve:

add implementation 'com.android.support:support-v4:28.0.0' in your
gradle

as an old version of com.android.support:support-v4:26.1.0 is there imported by some other library which is causing the issue with com.android.support:appcompat-v7:28.0.0, similarly add the other implementations that occur after this one.
so final would be like

implementation 'com.android.support:appcompat-v7:28.0.0' 
implementation 'com.android.support:support-v4:28.0.0'

###

add the below implementation in gradle file :

implementation 'com.android.support:support-annotations:28.0.0'

###

You must update your

compileSdkVersion 28   &   targetSdkVersion 28

then Use

   implementation 'com.android.support:appcompat-v7:28.0.0'
   implementation 'com.android.support:design:28.0.0'

This is the stable release of Support Library 28.0.0 and is suitable for use in production. This will be the last feature release under the android.support packaging, and developers are encouraged to migrate to AndroidX.

###

compileSdkVersion 28 & targetSdkVersion 28

change

Leave a Reply

Your email address will not be published. Required fields are marked *