Eclipse Android Change API Level-ThrowExceptions

Exception or error:

Once I have created a project with the Android wizard, how do I change the API Package from say 1.5 to 2.1 ?

I’m not referring to the application xml where the minimum API is set, I’m referring to the jar’s included in my project to the Google APIs.

How to solve:

Are you using Eclipse for this because you tagged the question with eclipse.
If you are using Eclipse just right click on your project select properties now choose android. You should now be able to select another build target. If you want to the API package change the checkbox from 4 to 7.

If you are not using Eclipse and want to use the Android console program use the terminal program android in the following way

android update project -p <path to project> -t <new target api level>

###

Using Eclipse, it may not change the SDK version correctly just going right click and properties. Open the manifest file and change the line

<uses-sdk android:minSdkVersion="number-of-version-you-want" />

Leave a Reply

Your email address will not be published. Required fields are marked *