Error Oven for Cake php #Error installing package cakephp/migrations-ThrowExceptions

Exception or error:

I’m a beginner in Cake. I’m trying to install it on a VM instance using the ubuntu server. I followed the requirements to install Cake PHP on ubuntu, install and configure apache2 and php7.2 according to the requirements of https://book.cakephp.org/4/en/installation.html .
Try to make a cake design using the composer. Get several problems and finish giving up. Finally, ending with the “Oven for cake”.

When filling out the forms to create the project in Oven I clicked “Install Cake PHP”.
The result was the Next. enter image description here

In the image log the following data.

/ var / www / html /texte

Checking path...
/var/www/html/texte directory is writable
Checking PHP version...
Your version of PHP is 5.5.9 or higher (detected 7.2.24-0ubuntu0.18.04.3).
Checking mbstring extension...
Your version of PHP has the mbstring extension loaded.
Checking openssl/mcrypt extension...
Your version of PHP has the openssl extension loaded.
Checking intl extension...
Your version of PHP has the intl extension loaded.
Installing composer...
All settings correct for using Composer
Downloading...

Composer (version 1.10.1) successfully installed to: /var/www/html/composer.phar
Use it: php /var/www/html/composer.phar


Creating CakePHP project...
Creating a "cakephp/app:~4.0.0" project at "./texte"
Installing cakephp/app (4.0.3)
  - Installing cakephp/app (4.0.3): Downloading (connecting...)Downloading (100%)
Created project in /var/www/html/texte

Installing cakephp/cakephp:~4.0.4...
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 14 installs, 0 updates, 0 removals
  - Installing psr/simple-cache (1.0.1): Downloading (100%)
  - Installing psr/log (1.1.2): Downloading (100%)
  - Installing psr/http-message (1.0.1): Downloading (100%)
  - Installing psr/http-server-handler (1.0.1): Downloading (100%)
  - Installing psr/http-server-middleware (1.0.1): Downloading (100%)
  - Installing psr/http-client (1.0.0): Downloading (100%)
  - Installing psr/http-factory (1.0.1): Downloading (100%)
  - Installing laminas/laminas-zendframework-bridge (1.0.1): Downloading (100%)
  - Installing laminas/laminas-diactoros (2.2.2): Downloading (100%)
  - Installing laminas/laminas-httphandlerrunner (1.1.0): Downloading (100%)
  - Installing composer/ca-bundle (1.2.6): Downloading (100%)
  - Installing cakephp/chronos (2.0.3): Downloading (100%)
  - Installing aura/intl (3.0.0): Downloading (100%)
  - Installing cakephp/cakephp (4.0.4): Downloading (100%)
cakephp/cakephp suggests installing ext-curl (To enable more efficient network calls in Http\Client.)
cakephp/cakephp suggests installing lib-ICU (The intl PHP library, to use Text::transliterate() or Text::slug())
cakephp/cakephp suggests installing paragonie/csp-builder (CSP builder, to use the CSP Middleware)
Writing lock file
Generating autoload files
Class Cake\Composer\Installer\PluginInstaller is not autoloadable, can not call post-autoload-dump script

How to solve:

Leave a Reply

Your email address will not be published. Required fields are marked *