Go app engine dev_appserver.py doesn't support runtime go112-ThrowExceptions

Exception or error:

I am trying to migrate my Go app to runtime go112, but dev_appserver.py throw the following error:

RuntimeError: Unknown runtime 'go112'; supported runtimes are 'custom', 'go', 'go111', 'java', 'java7', 'java8', 'php55', 'php72', 'python', 'python-compat', 'python27', 'python37'.

Current Go version is 1.12.11

Edit: I used apt-get to install the SDK.

apt-get update && apt-get install google-cloud-sdk google-cloud-sdk-app-engine-python\
    google-cloud-sdk-app-engine-python-extras\
    google-cloud-sdk-app-engine-java\
    google-cloud-sdk-app-engine-go\
    google-cloud-sdk-datalab\
    google-cloud-sdk-datastore-emulator\
    google-cloud-sdk-pubsub-emulator\
    google-cloud-sdk-cbt\
    google-cloud-sdk-cloud-build-local\
    google-cloud-sdk-bigtable-emulator\
    kubectl -y

That way it seems I can’t use gcloud components update and the packages are not up-to-date in the repos.

Now my questions is: Does google-cloud-sdk-app-engine-go support go runtime 1.12? If not, when will it support runtime 1.12?

Update: I installed cloud SDK and run gcloud components update successfully on another computer, dev_server.py still throw the same error. Does the local SDK actually support rumtime 1.12?

How to solve:

go112 runtime is not available on local dev_appserver.py. This has been discussed on the App Engine Go forum at

https://groups.google.com/forum/#!topic/google-appengine-go/kHxZ9zIb_QE

The expectation is that starting from go112 runtime, there is no “appengine” way of running the go server and works normally like any go server outside GAE. There are a few open issues like dispatching urls though.

Answer´╝Ü

It sounds like you gcloud SDK is an old version and not recognize “runtime: go112”, please run this command in order to update your SDK.

gcloud components update

After the update you can be able to deploy an app engine service using GO 1.12 runtime, check the changes that you need to perform in you App.yaml in this link

Leave a Reply

Your email address will not be published. Required fields are marked *