Jellybean (API 16) does not still show up on my Android SDK Manager-ThrowExceptions

Exception or error:

Is it just me or is anyone else not seeing the latest Android (Jellybean) showing up on their SDK manager? I’ve looked everywhere and it seems wherever I look, people are seeing it showing up on their SDK manager just fine.

I have updated by SDK tools to rev 20 and ran all other ADT updates.

I’m not in the US – and I’m wondering if this is still not available for non-US developers? I yet to come across anything that mentions this.

How to solve:

Try one of these:

  • Android SDK Manager > Tools (menu bar) > Settings > Manifest cache > Clear Cache (and maybe uncheck “Use download cache”)
  • If that doesn’t work, try running SDK Manager directly (i.e. not from within Eclipse). If running from Windows make sure you Run as Administrator.

###

For my case, I could only see Android 4.0.3 (API 15) whenever I open the SDK Manager outside Eclipse, “Reload” from the toolbar, or click “Options”. Just now, I installed the 2 things that it recommended for Tools, and then suddently everything shows up!

###

I had this problem, and was able to see the new repo after selecting:

Packages > Reload (from the SDK Manager toolbar)

###

I solve that by open AVD Manager from command promt…

Command(Window[Linux too]) : …/android-sdks/tools/android

###

In my case on MAC OSX problem was with version of my ADT, I downloaded the Latest Version of ADT from Android Installing Eclipse and Installed using Eclipse (Menu) Help–> Install New Software–>Add and selected the ADT zip file and when installation completed i restarted my Eclipse and then i choose (Menu) Window–>Android SDK Manager–> Packages–>Reload

This time It worked for me.

###

I solved the issue by updating my SDK tools. I downloaded latest “Android SDK Tools” and “Android SDK Platform-tools”.

Leave a Reply

Your email address will not be published. Required fields are marked *