Kotlin on Android – is there a minimum API level requirement?-ThrowExceptions

Exception or error:

I am seriously considering using Kotlin on a greenfield Android project, but am concerned about knock-on implications, the most significant of which is a minimum required API level.

On other platforms, new languages have required a certain OS version (e.g. Swift requiring iOS 7) and I wondered whether there were similar requirements here?

I’ve been searching through various Kotlin/Android FAQs and Stackoverflow but have not been able to find this information.

How to solve:

No. There’s no such requirement for the API level as these two are not directly related. Anyway, see official FAQ

Which versions of Android does Kotlin support?

All of them! Kotlin is compatible with JDK 6, so apps with Kotlin
safely run on older Android versions.

Leave a Reply

Your email address will not be published. Required fields are marked *