php – Having issues with ports in Xampp-ThrowExceptions

Exception or error:

I just finished making a site with WordPress. I want to make another site with the multi-site function. I followed some instructions and downloaded Xampp but Xampp keeps showing me errors and I can’t seem to find a solution to it.

1:39:21 AM [Apache] Problem detected!

1:39:21 AM [Apache] Port 80 in use by
“”C:\Bitnami\WORDPR~1.2-3\apache2\bin\httpd.exe” -k runservice” with
PID 4768!

1:39:21 AM [Apache] Apache WILL NOT start without the configured
ports free!

1:39:21 AM [Apache] You need to uninstall/disable/reconfigure the
blocking application

1:39:21 AM [Apache] or reconfigure Apache and the Control Panel to
listen on a different port

1:39:21 AM [Apache] Problem detected!

1:39:21 AM [Apache] Port 443 in use by
“”C:\Bitnami\WORDPR~1.2-3\apache2\bin\httpd.exe” -k runservice” with
PID 4768!

1:39:21 AM [Apache] Apache WILL NOT start without the configured
ports free!

1:39:21 AM [Apache] You need to uninstall/disable/reconfigure the
blocking application

1:39:21 AM [Apache] or reconfigure Apache and the Control Panel to
listen on a different port

1:39:21 AM [mysql] Problem detected!

1:39:21 AM [mysql] Port 3306 in use by “Unable to open process”!

1:39:21 AM [mysql] MySQL WILL NOT start without the configured ports
free!

1:39:21 AM [mysql] You need to uninstall/disable/reconfigure the
blocking application

1:39:21 AM [mysql] or reconfigure MySQL and the Control Panel to
listen on a different port

As you can see, there’s quite a few problems and I can’t really fix any of them. I uninstalled Skype because, from what I learned, Skype uses port 443 and 80. When I click the netstats option in Xampp, it shows that the both of these ports are used by httpd.exe

How to solve:

Leave a Reply

Your email address will not be published. Required fields are marked *