php – phpdocumentor/reflection-docblock package issue-ThrowExceptions

Exception or error:

I have this problem on server CLI, the project in Laravel 6 and server is in ubuntu

Problem 1
        - Installation request for phpdocumentor/reflection-docblock 5.0.0 -> satisfiable by phpdocumentor/reflection-docblock[5.0.0].
        - phpdocumentor/reflection-docblock 5.0.0 requires ext-filter ^7.1 -> the requested PHP extension filter has the wrong version (7.2.28-3+ubuntu16.04.1+deb.sury.org+1) installed.
      Problem 2
        - phpdocumentor/reflection-docblock 5.0.0 requires ext-filter ^7.1 -> the requested PHP extension filter has the wrong version (7.2.28-3+ubuntu16.04.1+deb.sury.org+1) installed.
        - phpspec/prophecy v1.10.2 requires phpdocumentor/reflection-docblock ^2.0|^3.0.2|^4.0|^5.0 -> satisfiable by phpdocumentor/reflection-docblock[5.0.0].
        - Installation request for phpspec/prophecy v1.10.2 -> satisfiable by phpspec/prophecy[v1.10.2].
      To enable extensions, verify that they are enabled in those .ini files:
        - /etc/php/7.2/cli/php.ini
        - /etc/php/7.2/cli/conf.d/10-mysqlnd.ini
        - /etc/php/7.2/cli/conf.d/10-opcache.ini
        - /etc/php/7.2/cli/conf.d/10-pdo.ini
        - /etc/php/7.2/cli/conf.d/15-xml.ini
        - /etc/php/7.2/cli/conf.d/20-calendar.ini
        - /etc/php/7.2/cli/conf.d/20-ctype.ini
        - /etc/php/7.2/cli/conf.d/20-dom.ini
        - /etc/php/7.2/cli/conf.d/20-exif.ini
        - /etc/php/7.2/cli/conf.d/20-fileinfo.ini

      You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.
How to solve:

Leave a Reply

Your email address will not be published. Required fields are marked *