php upgrade error: Your requirements could not be resolved to an installable set of packages-ThrowExceptions

Exception or error:

I’m trying run a project requiring php 7.2.5 or higher. When I run php -v it says I have 7.1.23. Following other online advice, I’ve run

curl -s https://php-osx.liip.ch/install.sh | bash -s 7.3

to upgrade versions. At that point I get the message “your requirements could not be resolved to an installable set of packages” followed by a list or problems all saying I have an old version of php.

The other thing I read was to run

brew upgrade php

at which point it tells me “php not installed”

When I go back and run a version check it tells me I have the old version as seen above. What am I doing wrong? I’ve never worked with PHP and have no idea how to upgrade or where to save it.

How to solve:

Leave a Reply

Your email address will not be published. Required fields are marked *