React-Native Lowest Android API level-ThrowExceptions

Exception or error:

I am doing some research on react-native and android. Does anyone know the lowest api level react-native supports for android? I’ve searched all over their docs page and couldn’t find it.

How to solve:

Supported operating systems are >= Android 4.1 (API 16) and >= iOS 9.0.

https://github.com/facebook/react-native/releases/tag/v0.56.0

###

iOS minimal version has changed to >=8.0, follow the link, right after the first paragraph of the readme

###

In their build version from 0.38 & above i believe they have upgraded lowest supported android API to 6.0(Marshmallow) as specified on the official website

http://facebook.github.io/react-native/releases/0.40/docs/getting-started.html#content

They seem not to have updated the information on the GIT docs.

Leave a Reply

Your email address will not be published. Required fields are marked *