svn – "Subversion command line client version is too old" error in Android Studio-ThrowExceptions

Exception or error:

Whenever I open a project in Android Studio, I’ll see this error:

Error

When I click “Fix it”, it will show this window:

Fix it

I don’t know what to do because I’m running TortoiseSVN 1.9.0, which is the latest version.

What should I do to fix this error? Thanks for your help.

How to solve:

It’s just misprint: must be “too new”

Android Studio based on Intellij IDEA, Intellij 14.1.4 cannot use svn 1.9.0

###

Intellij IDEA 14 works with SVN 1.9, it just shows a warning: https://youtrack.jetbrains.com/issue/IDEA-140754

###

Svn 1.9 command line client should work in IDEA – just warning (you can close it) is shown.
upgrade new version 14.1.5 from https://confluence.jetbrains.com/display/IDEADEV/IDEA+14.1+EAP or 15 EAP: https://confluence.jetbrains.com/display/IDEADEV/IDEA+15+EAP .

https://devnet.jetbrains.com/thread/471975

###

As Lazy Badger says, it should say is too new.

Faced same problem on Debian. I had 1.9 version installed. I fixed it by removing my installed version and then installing 1.8 version:

aptitude remove subversion
aptitude install subversion=1.8.10-6+deb8u1

EDIT
As I understand, the devs of Android Studio have fixed this issue in latest releases.

###

In my case it was related with broken path:

xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun

Issue was resolved after installing xcode-select:
xcode-select --install

Leave a Reply

Your email address will not be published. Required fields are marked *